
Configurator: The Family History
Configurator is based on a new technology introduced 
by Adobe in early 2008. “AIR”, which stands for Adobe 
Integrated Runtime, is a development environment, (a 
system run-time multi-platform) that allows develop-
ers to create desktop applications using web develop-
ment tools and technologies such as Flash and Flex 
(Flash Builder), and Adobe’s AJAX, HTML, Javascript 
or some combination. Applications developed in this 
environment are identified by an .air suffix (Figure 1).

These applications 
are cross-platform 
and can be used di-
rectly on your com-
puter regardless of 
operating system. 
They require that 
AIR be installed. All 
Adobe products, in-
c l u d i n g  Cre a t i ve 
Suite, install it auto-

matically. If for some reason you don’t have it, you can 
download it at http://get.adobe.com/air/.

Our installer can be opened like any other file, ex-
cept that you must have Photoshop installed. You do 
not have to have the Configurator application itself 
unless you are planning to develop your own panels. 
If you wish to do so, Configurator is a free download 
at: http://labs.adobe.com/downloads/configurator.
html.

This brief introduction explains why you occasion-
ally receive notification of updates to AIR when you 
are using Configurator or any other extension pro-
gram that requires it. If you see a window like Figure 
2, you should proceed with the update.

AIR: What Is It?
Applications based on AIR technology are called RIAs, 
Rich Internet Applications that run locally.

These applications are able to interact with the op-
erating system, our local computer, and a web server 
to receive data from the Internet and view it locally 
without the help of a browser. They are somewhat of 
a middle ground between web-based applications 
(which require a browser) and traditional desktop 
software such as Photoshop or Excel.

Given the integration of Flash panels in Photo-
shop, for example, these characteristics allow Adobe 
Configurator to display movies from the Internet and 
access other external resources. Photoshop will be 
able to control and interact via the Web application to 
send commands through its scripting system.

AIR, in practice, acts as a shell, allowing these ap-
plications to work locally on our computers and by-
pass the limitations posed by a web browser.

The Two Versions Of Configurator
Adobe Configurator is a free utility that allows us to 
create custom panels for Photoshop CS5. These sim-
ple words scarcely hint at how useful the concept is, 
or its many potential fields of application and amaz-
ing potential.

The first two releases of Configurator are version-
specific, creating panels that work only in one version 
of Photoshop.

Configurator 1.0 can only create panels for Photo-
shop CS4.

Configurator 2.0 can only create panels for Photo-
shop CS5 or InDesign CS5.

The two versions are basically incompatible be-
cause there have been significant programming 
changes. Version 2.0, however, can import panels 
created with 1.0 and repurpose them for use in Pho-
toshop CS5.

Why Configurator Is Almost Unknown
Configurator has remained in the shadows since its 
first release. Although it is being used by some pro-
grammers, businesses and individual Photoshop or 
InDesign professionals, its use cannot be said to be 
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Figure 1. The usual icon of an AIR 
application. 

1

2

http://get.adobe.com/air/
http://labs.adobe.com/downloads/configurator.html
http://labs.adobe.com/downloads/configurator.html


widespread.
The reasons are somewhat mysterious, but among 

the leading causes I would offer three possibilities.
1.	 The first is that the proliferation on the market of 

a huge amount of products. The documentation 
of what they do is often inadequate. This makes it 
even more difficult to comprehend the usefulness 
of a new product, considering that all of us are 
being forced to cut the amount of time dedicated 
to learning to the bare minimum.

2.	 The second is surely due to various limitations 
in the first released version of Configurator, 1.0. 
Sins of youth are of course understandable, but 
as I said, time is precious, and we insist on getting 
everything at once.

3.	 The third is in my opinion the most important 
and extends beyond Adobe Configurator.

Photoshop and the entire Adobe Creative Suite 
offer many methods of automation. They constitute 
one of the most important offerings of the product, 
yet are generally poorly understood. Batching, scripts, 
droplets, actions, commands, panels, workspaces are 
words that we all know, some more intimately than 
others, but they are not always used properly in the 
workflow. Some automation methods are used un-
knowingly. Conversely, some remain abstract words 
that have meaning only on paper but do not seem 
to have much to do with your workflow. Whichever 
the reason, the result is that they very often are not 
exploited fully.

It is weird that, for example, hardly anyone who 
uses Photoshop actions combine them with other 
methods of automation. Among the available possi-
bilities, for example, is to attach a condition to be met 
before the action is performed on the image. 

Here is a practical example to clarify what I am 
talking about: if you create an action designed to act 
exclusively on an RGB file, we could enter, or better, 
record into the action a conditional step to recog-
nize the image’s colorspace and convert it through 

Fi le>Automate> 
Conditional Mode 
Change (Figure 3).

You can en-
able only the RGB 
c h e c k b o x  l i k e 
shown in Figure 4 
and select the con-
version you want 
in the target mode 

section and then proceed recording  further steps of 
the action. This one will stop if the image is in a differ-
ent workspace than RGB.

If you want to resize your images considering both 
Landscape and portraits, you can insert the fit Image 
automation from the menu File>Automate and in-
serting the same value in both width and High field 
(Figure 3).

Or attach an action script like shown in Figure 5 
or a batch when a certain event is met. An example 
would be to automatically add metadata, such as 
author and copyright information, each time a file is 
opened.

These are just two examples of synergy between 
methods of automation, and many more examples 
could be offered. But it requires a thorough knowl-
edge of the various possibilities offered by each 
method to understand how far we can push the en-
velope. Of course we can go further through scripting 
with AppleScript, JavaScript or VBScript, which are in 
the realm of “advanced automation”, but we would go 
far beyond the scope of this article. I want to show, in-
stead, how Configurator’s power and ease of use can 
meet the most demanding needs for customization.

Photoshop’s automation possibilities are almost 
unlimited. Through scripting you can get things oth-3
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erwise unimaginable, but one need not be an expert 
to use what’s ready to go in Photoshop. There are 
limitations, of course, but one can go well beyond the 
normal use of the program.

What Is Automation?
Before exploring the many issues to which automa-
tion can be put in Photoshop it is perhaps best to ask 
what the word means.

A filter, for example, which changes the appearance 
of the image, could be considered an automated pro-
cess, as it generates new pixels based on the sum or 
combination of multiple steps or calculations.

A panel, even if it doesn’t directly modify the image, 
should be considered as an automated storage of ob-
jects designed to speed up your workflow. It therefore 
can be seen as a container of multiple automation 
tools.

We therefore have an absolute definition of auto-
mation as a utility instrument.

In reality, however, the concept of automated util-
ity is also often associated with something not par-
ticularly productive, and therefore is thought to be of 
secondary importance.

A filter produces a visible change in the image pix-
els and, if properly applied, the small investment of 
time is always justified. A utility is often dismissed as 
either a waste of time or something that can be done 
without. Nothing could be more mistaken.

Instead both should be considered for their char-
acteristics.

We’ll talk about automation, considering only those 
functions whose characteristic is the combining of 
multiple steps into a single one, to be executed without 
further manual intervention whenever we want.

Consider these tools to organize commands, tools 
and automatic single argument to make our workflow 
more efficient, keeping everything at your fingertips.

Automating Repetitive Tasks
Personally, although if the question is purely sub-
jective, I use a filter only if it is a way to save time or 
returns a result I cannot replicable with other tradi-
tional tools of Photoshop. But I cannot do without 
certain amenities such as batch processing, actions, 
and scripting, which reduce the hundreds of steps in 
Photoshop to a single click, allowing me to reapply the 
effect or to replicate a fixed workflow whenever I like.

My slothfulness is fairly well known, and if to cor-
rect a certain sky requires ten steps, I might well 
decide to forego the privilege. Doing it with an auto-

mated mechanism such as a simple action is more 
inviting, allows more time for creativity and image 
analysis, and permits making several variations and 
choosing the most satisfying result.

Processing hundreds of photos that all need the 
same changes can become tiresome. What better so-
lution than automation? A workflow punctuated by 
repetitive steps or one that needs to be replicated at a 
later time can benefit today from many tools available 
in Photoshop proper or produced by third parties.

Through automation Photoshop can be trans-
formed into an interactive tool that lets us work faster, 
saving time improving workflow, and increasing pro-
ductivity in both quantitative and qualitative terms.

The Battle
I always like to imagine our daily life as taking place 
in a comic strip by Walt Disney. In this fanciful reality, 
Photoshop would certainly be portrayed as a battle-
field and the pending image as the enemy that offers 
us combat.

Before us in the field are soldiers (automation) 
and the weapons granted to me (commands, curves, 
filters, etc.) I try to coordinate and devise, as a good 
general would, a battle plan (or action plan), taking 
into consideration what the most useful tactics will be 
for my purposes, and what alternatives I have to deal 
with different situations that may arise.

I would try to entrust specialized jobs to the 
“troops” (actions). I would not hesitate to put “tanks” 
(batch events, scripts...) into the field for the most 
repetitive work.

For managing these elements, I would put my faith 
in two excellent organizers within Photoshop: work-
spaces and panels (both those provided by Photo-
shop and custom ones from other sources).

Workspaces will pre-configure the battle plan. 
Panels will be the base camp areas with a utility that 
subdivide the weapons into groups organized by type 
and for maximum efficiency. The risk is great. Who will 
win? I may be the victim and lose the battle completely.

It goes without saying that we must have the skills 
to face a battle. Concentration and focus are still the 
winning army, marching straight to the objective with 
no distractions.

Some might argue that a lot of time is lost  during 
the preparations, but the answer is equally obvious: 
the reward is far greater than the time spent.

We should also take into account that:
1.	 Preparations today will also be used for other 

battles in the future.



2.	 We will then be facing a type of enemy that has 
been previously defeated.

3.	 Our losses will be minimal, which means that 
the quality of the battle has been excellent.

What Is Configurator’s Role?
The first time I opened Configurator I thought im-
mediately that it is the ideal tool, finally, to organize 
actions created in Photoshop. Without it, as the Ac-
tions palette fills up over time it becomes increasingly 
easy to get lost in the bedlam of actions loaded and/
or created. The effort of searching the palette for the 
desired action gets really exhausting.

As time went on I came to appreciate the great 
potential of this program, which can be considered 
as the younger brother of Adobe Flex (a program for 
creating extensions, now become Flash Builder). It 
lacks a fair number of tools  found in its older brother, 
but noting the big change for the better after the first 
release, I expect for more and more functionality and 
larger libraries in the future.

Looking beyond the current features of Adobe Con-
figurator reveals a vista of tremendous potential. This, 
however is not the time to talk about them. I would 
avoid talking about technologies that need to be ex-
plained in detail and would make little sense for those 
just becoming acquainted with this software.

The important thing is to understand how fast, easy 
to use, and helpful in their workflow this product can be.

All the tools in Photoshop are at your disposal and 
you can organize them as you wish. You can regroup 
and launch specific actions, scripts, various auto-

mated procedures, filters, retrieve palettes and on 
and on. This way  you can design a specific panel to be 
used depending on the workflow that you face.

For example, you could create panels for specific 
work streams for printing, or for different printing 
conditions, panels for the production of images for 
web, etc. Organize all the individual steps for a par-
ticular workflow, and group the most useful tools so 
they don’t get lost meandering through the maze of 
Photoshop menus.

In short, you can stay focused on your goal without 
distractions. You can share the panel between differ-
ent computers, pass it on to others, create tutorials, 
insert movies to be viewed in Photoshop, load web 
pages images that reside on the network or make use 
of external elements such as Flash files.

Once you start using Configurator, it will be your 
own imagination and needs that will guide you to 
greater productivity.

Configurator, a Practical Example
An important and instructive example of Configu-

rator’s use is the panel shown in Figure 6 to 9 that fol-
lows the Picture Postcard Workflow (PPW).

This panel clearly shows the utility of Configura-
tor, although some features were implemented with 
scripting. It also demonstrates a dual utility, for it is 
as profitable for the savvy followers of this workflow, 
as it is for users who are just beginning to adopt this 
effective and logical system for image correction and 
enhancement developed by Dan Margulis.

You can run all the actions and Photoshop com-
mands in just one click,you can read 
documentation without leaving pho-
toshop, you can update the panel 
and all its content at the same time 
in just a snap.

All the tools you need at your fin-
gertips to follow the flow as quickly 
as possible without wasting time 
searching for what you need. Just as 
you would with the television remote 
control.

Configurator Is Child’s Play
Whoever thinks that is complex to use 
Configurator panels may be disap-
pointed.

The learning curve is like the con-

Figure 6 and 7. The PPW TOOLS panel in 
the Advanced and Normal mode.
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trast curve of Dan Margulis: “steep” in the sense that 
comprehension comes quickly and leads to many prac-
tical uses. This is a characteristic of good software. Con-
trary to what some think, the better designed and struc-
tured a program is, the more intuitive and less complex 
the interface, and the easier to use and understand.

And the results can be likened to the effects of the 
Color Boost action, or Margulis himself: always colorful.

Although it is always a good idea to read the manual, 

particularly one as thorough as ours, the fact 
is that it may not make much of a difference. 
The work environment is extremely simple 
and very intuitive. The interface is divided 
into three main areas like shown in Figure 
10 and we believe it is virtually impossible 
to get confused or go wrong. In the first 
section you find the menu shown in Fig-
ure 11. Here, there’s nothing to explain as 
it’s really self intuitive. Just below, there’s 
a search field to quickly find the tool or 
command you are looking for (Figure 12).

Underneath, you can find the Object 
menu from which you can drag  and drop 
on the stage: tools; every Photoshop com-
mand, even the sub menus and palette 
menu ones; buttons to run your actions; 
script to insert and script that reference 

to an external file; widgets for inserting 
text, images, movie, external panel, an 
html page; and finally containers object to 

display and access to your contents (Figure 13 to 17).
The middle section is the canvas where you’ll create 

your panel. After choosing File>New Panel, a panel of 
220x220 pixel is created by default (see handled box 
in section 2). This is your actual working area. You can 
drag the handles to resize the panel manually or you 
can insert the exact size in pixel in the Panel section 
on the right (section 3).

From the Object menu on the left you can select 
any element and drag 
it into the panel. Once 
it’s inside the panel, you 
can manually resize it 
by moving its handles or 
can set the exact size in 
pixels in the Inspector 
(section 3) on the right.

Now, let’s take a look 
at this section, actually 
the most important. The 
Inspector is a contextual 
area in which the upper 
part is always related 
to the panel itself. Un-
derneath you’ll find the 
Oject section in which 
every field changes de-
pending on what is cur-
rently selected in the 
panel (buttons, contain-

Figure 8 and 9. The two additional panels inside the PPW TOOLS: the preferences 
for some of actions available and the layout, and the documentation accessible 
through the help button in the main panel shown in Figure 6 and 7.
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ers or anything else). 
For every element 
you can set its name, 
size, position and 
any other parameter 
necessary for its full 
functionality.

E v e r y t h i n g  i s 
quite intuitive: all 
you need is to follow 
the meaning of the 
words and you’re on 
the right track.

Let’s give an easy 
example. Drag on 
the panel an action 
button taken from 
the menu on the left. 
While keeping it se-
lected, you can link 
it to an action by in-
serting, in the Object 
section, the Action’s 
Name and Set that 
you have previously 
created inside Pho-
toshop (Figure 18). 
To avoid errors you 
can copy the action’s 
name directly from 
the Actions palette 
in Photoshop and 
then paste it in the 
right field. The same 
can be done for the 
Action set’s name. 
The button’s size can 
be adjusted manu-
ally by dragging the 
handles or, for a 
more precise work, 
you can insert the 
exact size and po-
sition in the object 

section like shown in Figure 18. So easy? Yes, indeed.
Now, let’s suppose that you want to insert some 

graphics for giving a more customized look at you 
panel. From the image tools menu on the left, just 
select “SWF or Image Loader“ (Figure 17) and drag it 
into the panel. Adjust the size and then click on the 
icon besides the Location field. You’ll be prompted to 

choose the file you 
want to use. It can 
be an image or 
any other media, 
but here comes 
a little trick. You 
should create a 
folder inside the 
one containing 
your panel to be 
sure that the link will be a relative one (images/item.
jpg) like shown in Figure 19. Also, the image you’re 
going to use should be the same size in pixels of your 
container, if  you don’t want it to be rescaled by Con-
figurator.

Once you have completed your panel with all the 
buttons and graphics, it’s time to export it. First, I 
would suggest to take a final look at what you have 
created by choosing Preview Panel from the File 
menu. Here, you’ll have a good idea of how the panel 
will look once you’re in Photoshop and can test all the 
buttons. After that, you can finally export your panel 
directly into the Photoshop Plug-ins folder by choos-
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ing Export Panel  from the File menu. 
When you’re prompted, choose the Plug-ins folder 

into the Adobe Photoshop CS5 folder, and you’re 
done. Easy, isn’t it? You will need to quit and reopen 
Photoshop in order to use the panel and, for showing 
it, you will need to choose Window>Extensions>your_
panel.

If you want to share your panel with someone else, 
the procedure can be done in two ways. The first is 
fully manual. Go into the folder Adobe Photoshop 
CS5>Plug-ins>Panels and copy the panel’s folder to 
the desired location on your disk. Before sending it by 
e-mail, it’s a good idea to compress your panel’s folder 
into a .zip file.

A second and smarter way can be to create an in-
staller with an easy procedure that requires different 
steps. I would leave this pleasure to you by taking a 
look at the manual. Like you’ll see it isn’t complicated 
at all, like many other things in Configurator.

Now, few technical notes. You can work on many 
panels at the same time, as shown in Figure 22, and 
you can copy and paste any element in all of them. 

Though Configurator is a simple software, it’s not 
really an evoluted one, not yet at least. This means 
that you can create panels for anything you need, but 
for more complicated purposes you’ll need to find 
out more complicated solutions. Scripting is one of 
them and it’s not suitable for the average user, unless 
you’re confident with the scripting language used by 
Configurator.

If you want to investigate this or go more in depth, 
I would suggest you to access first the Help documen-
tation by clicking on the question mark on the right 
in the bar shown in Figure 21. If not enough, there 
are some online resources you can access, but not so 
much.

Anyway, I think that what we have seen so far can 
help 90% of users to speed up and automate any com-
mon but ripetitive task in daily use.

The PPW TOOLS panel was actually created in line 
with this philosophy, as it speeds up the workflow cre-
ated by Dan Margulis, and you may desire to create 
your own one for the same good reasons.

 So, don’t be scared. Open Configurator and start 
to build your panel. I can assure that, after the very 
first time, you will be addicted to. And you will find it 
much easier than you may think. Granted.
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